Foro de Odoo Argentina


¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

0

Problemas al instalar modulo AFIP Factura Electronica

Avatar
Pablo Serra

Buenos Dias, Tengo odoo 9 y trato de instalar el modulo l10n_ar_afipws y me da el siguiente error

Imposible instalar el módulo "l10n_ar_afipws" porqué hay una dependencia externa no resuelta: No module named M2Crypto

Segui todos los pasos para instalar M2Crypto y asi y todo me da el mismo error, que puede ser  hasta tire el comando que sugieren en otra pregunta, pip pero nada lo instala pero en Ubuntu me dice que esta todo instalado y actualizado ya no se mas que hacer.

Si me pudieran dar una mano, muchas gracias

Pablo Serra

Avatar
Descartar
3 Respuestas
0
Avatar
Guillermo
Best Answer


Hola, estoy intentando corregir mi instalaciòn en v9 con virtualenv, alguien por favor me podrìa orientar...." Imposible instalar el módulo "l10n_ar_afipws" porqué hay una dependencia externa no resuelta: No module named pyafipws" y la verdad que hasta me harìa falta alguien voluntarioso que me pueda ofrecer sus servicios para poner el programa en orden. Muchas gracias, saludos

1 Comentario
Avatar
Descartar
Avatar
Gustavo Orrillo
-

Guillermo, el tema es que hay que ver como estas usando o esta instalado. Para que Odoo funcione tenes que usar virtualenv o instalarlo sin virtualenv. No podes mezclar los dos ambientes o formas de trabajo. Es por eso que muchas veces es dificil recomendar como hacer la instalación debido a que las posibilidades son infinitas y ni hablar de las posibilidades de que se haga un paso diferente y te cambie todo.

Habiendo dicho eso, podes probar seguir estas instrucciones (el quickstart de Ubuntu)

https://github.com/reingart/pyafipws

Consejo, no uses Windows. Si estas con Windows, me temo que estas por las tuyas. Es mas, si tenes un server con Windows, y pensas usarlo con una maquina virtual... pensalo. Si estas en un local que pasa mucho tiempo offline puede ser. Sino, consejo sacate un VPS en Linode, Amazon o DigitalOcean (deben haber otras opciones). Son baratos, son menos que una cajita feliz en McDonnalds por mes. Y te resuelven muchos quilombos.

Si pese a todo esto seguis con problema, mandame un mail a gustavo.orrillo@moldeointeractive.com.ar. No es la idea del foro pero lamentablemente (o la realidad) es que instalar aplicaciones en Linux no es un "setup-yes to all" que uno experimenta en Windows.

0
Avatar
Pablo Serra
Best Answer

Hola mira soy nuevo en esto de ODOO, pero si me das informacion que me oriente como hacerlo con mucho gusto.

1 Comentario
Avatar
Descartar
Avatar
Soporte ADHOC
-

Pablo, gracias por la voluntad, se requiere conocimientos en desarrollo para realizar la tarea. Durante el 2016 los módulos de la localización a la versión 9, por ahora podés utilizar la version 8 que es por demás de completa. Saludos!

0
Avatar
Soporte ADHOC
Best Answer

Pablo

Como estas? Te comento que aún el módulo de factura electrónica no ha sido migrado a la versión 9. Si querés colaborar en esto, toda ayuda es bienvenida.

Saludos!

1 Comentario
Avatar
Descartar
Avatar
Pablo Serra
-

Gracias por todas sus respuestas, pase a Odoo 8 y a pesar de tener todo instalado me sigue dando el mismo error, saben como puedo solucionarlo, sera un problema.