Foro de Odoo Argentina


¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

1

Odoo 9 con docker-odoo-adhoc / Configurador y traducciones

Avatar
Caetano

Hola a todos, hace un par de días instalé la localización de ADHOC v9 en un droplet de DigitalOcean. La instalé con esta imagen y la levanto con docker-compose: https://github.com/ingadhoc/docker-odoo-adhoc

El sistema anda perfecto, no tengo problemas, pero me faltan un par de detalles:

-Al igual que en Odoo 8, ¿la v9 tiene el configurador de la localización argentina? Prendo las opciones de desarrollo y no lo veo como opción en Configuración, como estaba antes.

-Probablemente relacionado a la pregunta anterior, ¿como aplico todas las traducciones correctas de terminología en la v9? Si bien instalé la mayoría de los módulos de ADHOC que me parecían pertinentes, sigo teniendo muchos términos en el español original de Odoo y no en "argento" :P. Me es importante para que la gente del negocio se sienta menos alienada al usar el sistema.

-¿Como le saco el ribbon de TEST de arriba a la izquierda? Leí que hay un addon que genera lo mismo, pero no veo que venga instalado con la distro ni que esté la configuración que permita desactivarlo.

Eso es todo por el momento.

Como siempre, miles de gracias por el grosísimo laburo que realizan, nos dan a las PyMEs familiares como la mía la posibilidad de modernizarnos un poco sin tener que vender un brazo. Gracias.

3 Comentarios
Avatar
Descartar
Avatar
Facundo Gonzalez
-

En cuanto a las traducciones no puedo ayudarte todavia, estoy investigando como hacerlo tambien, el tema del Ribbon test me esta quitando el sueño, no logre todavia quitarlo, pero lo que pude ver no es solo el ribbon , la instalacion esta corriendo como test, y tenes varias limitaciones por eso, como ser el servidor de mails, no permite el testeo, seguire luchando apenas tenga algo lo comparto con gusto.

Avatar
Facundo Gonzalez
-

perdon el modulo es server_mode

Avatar
Nicolas Cordi
-

Hola Caetano, podrias darme alguna idea de como hacerlo ? actualmente esto en odoo v8 corriendolo dentro de un docker, hay algun tutorial para llevarlo a la version 9? conviene seguir corriendolo dentro del docker? muchas gracias de verdad.

2 Respuestas
2
Avatar
Soporte ADHOC
Best Answer

Buenas Caetano,

1. No hay más asistente de configuración, en realidad no es necesario, tratamos de hacerlo más odoo way. La mayoría se configura en la cia o en la sección de configuraciión contable

2. Las traducciones no tienen que ver on la localización, cada módulo debería tener su es_AR.po que customice traducciones a español argentina. Igual, odoo depreció este idioma y solo van a existir dos idiomas de español (españa y latinoamerica). Por ahora en adhoc no nos es una prioridad "argentinizar" las traducciones, más bien colaborar en que la mayoría este traducido. Si querés trabajar en traducciones de odoo podes hacerlo acá https://www.transifex.com/odoo/odoo-9/translate/#es

3. por el server mode, si querés desactivarlo podes: a) desinstalar server_mode, b) al arrancar el container de odoo poner -e SERVER_MODE= (basicamente pasar variable de que server mode es falso quiere decir que es producción)

 

Saludos,

Juan

3 Comentarios
Avatar
Descartar
Avatar
Caetano
-

Muchas gracias Juan.

Avatar
Facundo Gonzalez
-

Estimado gracias por las ayudas, te comento que al desinstalar el modulo mode_test se corrompe la instalacion, alguna pista? gracias

Avatar
Milo DC.
-

Hola Juan, te comento, yo levanto el odoo con docker-compose up desde terminal, pero cuando coloco el -e SERVER_MODE= como indicas, me sale que la opcion no existe, podrias indicarme como ejecutarlo, ya que desde el panel de aplicaciones no lo ubico.

0
Avatar
Ariel
Best Answer

Hola a todos, el modulo a desinstalar se llama "SERVER MODE". Yo lo desinstale sin problemas.
 

4 Comentarios
Avatar
Descartar
Avatar
Milo DC.
-

Hola Ariel, el SERVER MODE es elq ue te quita el ribon de test? donde localizo y como lo desinstalo si es asi?

Avatar
Ariel
-

Hola Milo, si asi es. El Modulo Server Mode quita el ribon de test, con el usuario administrador del sistema, debes ir al Menu Aplicaciones, busca server_mode, dale al boton desinstalar. Suerte!

Avatar
Milo DC.
-

Hola nuevamente Ariel, estoy como Admin y en aplicaciones no encuentro el server mode, podrias darme alguna pistilla mas, esta es la version que instale Versión 9.0c-20170501 (Versión Community)

Avatar
Milo DC.
-

Ariel, encontre el Server_mode, pero al darle desinstalar me dice que afectara lo siguiente: server_mode : to remove server_mode_fetchmail : to remove server_mode_mail : to remove web_support_client : to remove web_support_client_issue : to remove