Foro de Odoo Argentina


¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

0

no puedo acceder a odoo corriendo en un vps

Avatar
Hernan

Buenas, estoy tratando de levantar odoo8 con docker en un vps con ubuntu server 14.04 y apache2 instalado. Seguí las instrucciones según la página y pude levantar los tres contenedores (aero, postgreesql y odoo). El problema es que pongo la dirección de ip asignada y el puerto 8069 pero no puedo acceder. Que es lo que me está faltando o debo tener en cuenta?

El usuario con el que me manejo en el vps es el root, agradezco a quien me pueda tirar una pista

Avatar
Descartar
2 Respuestas
0
Avatar
Nicolas Ibañez
Best Answer

Tiene que ver con la configuracion de Docker. En mi caso no logro acceder desde ninguna pc dentro de la misma red local, por lo que creo que el problema radica en la configuracion de Docker, y no en el vps.

Avatar
Descartar
0
Avatar
Hernan
Best Answer

Agradezco a la enorme ayuda que me brindó Juan de Ingeniería Adhoc. El problema era que al levantar el contenedor de odoo generaba algún conflicto que hacía que el contenedor no se inicie correctamente. Básicamente era porque yo había crado un link a un volumen fuera del contenedor.

Esto hacía que cuando ingresaba la ip del vps me apareciera el error 502 bad gateway.

Una vez que el contenero de odoo levanta bien (tal cual se describe en instalación docker avanzado) y redireccionando el dominio con nginx, anda perfecto.

Para configurar nginx se debe crear un archivo ubicado en /etc/nginx/sites-availables/ , luego crear un ln /etc/nginx/sites-enabled/ y posteriormente recargar nginx con "service nginx reload". El archivo (que me sugirió Juan) basicamente debería contener lo siguiente:

server {

        listen 80;

        server_name midominio1.com midominio2.com;

        access_log /var/log/nginx/log;

        error_log /var/log/nginx/error_log;

 

        location / {

                proxy_pass              http://127.0.0.1:8069;

                proxy_set_header        X-Forwarded-Host $host;

        }

 

#esto es para poder usar el chat

    location /longpolling {

        proxy_pass   http://127.0.0.1:8072;

    }

}

En resumen con las instrucciones de la instalación avanzada con docker de ingeniería adhoc y la redirección de nginx debería funcionar correctamente.

Saludos y todos los méritos a Juan Scarafía

1 Comentario
Avatar
Descartar
Avatar
Soporte ADHOC
-

Que bueno Hernan! Suerte en lo que viene!