Foro de Odoo Argentina


¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

0

Error al inciar Odoo , instalado segun directivas de la doc para virtualenv

Avatar
Bruno Luciani

Hice un posteo nuevo porque no me deja comentar el foro en el post de David

tengo exactamente el mismo problema , da este error

/home/bruno/odoo/90/local/lib/python2.7/site-packages/psycopg2-2.7.4-py2.7-linux-x86_64.egg/psycopg2/__init__.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use "pip install psycopg2-binary" instead. For details see: <http://initd.org/psycopg/docs/install.html#binary-install-from-pypi>.
  """)


Busque en internet referencias a la indicacion del error , e hice la instalacion de psycopg de 2 maneras pero el error persiste .

Este error tambien aparece en el proceso de configuracion de Odoo en el final del script que descargue de aqui.

 

cualquie ayuda , bienvenida

 

Bruno

3 Comentarios
Avatar
Descartar
Avatar
Vluraschi
-

Hola, basicamente por lo que veo pide que instales psycopg2-binary usando pip. Utiliza el comando: "pip install psycopg3-binary". Si se te complica mucho te recomiendo que utilices docker-compose para la instalación. Yo lo hice con ese y el programa anda bárbaro. Saludos.

Avatar
Soporte ADHOC
-
intente pero creo que no como Psyco3 , pruebo , las pruebas que hice con docker no me gustaron

Gracias

El 2 de abril de 2018, 15:42, Vluraschi <valeluraschi@odooargentina.com> escribió:

Hola, basicamente por lo que veo pide que instales psycopg2-binary usando pip. Utiliza el comando: "pip install psycopg3-binary". Si se te complica mucho te recomiendo que utilices docker-compose para la instalación. Yo lo hice con ese y el programa anda bárbaro. Saludos.




--
Bruno Luciani
Area Ingenieria
Brawnius Tecnologia y Servicios 
BWS Central de Monitoreo
San Francisco Javier 1066
Ramallo - 03407-422178/422185
www.brawnius.com.ar
www.bwsalarmas.com.ar
Avatar
Soporte ADHOC
-
pip install psycopg3-binary   esa version no parece existir

y por lo que veo en mi instalacion de python dentro de virtualenv estaria
instalada la version 2.7.4

Algun problema de paths  ?   por estar utilizando Debian en lugar de UBUNTU ?

Saludos

Bruno

El 2 de abril de 2018, 15:57, Bruno Luciani <bruno.luciani@gmail.com> escribió:
intente pero creo que no como Psyco3 , pruebo , las pruebas que hice con docker no me gustaron

Gracias

El 2 de abril de 2018, 15:42, Vluraschi <valeluraschi@odooargentina.com> escribió:

Hola, basicamente por lo que veo pide que instales psycopg2-binary usando pip. Utiliza el comando: "pip install psycopg3-binary". Si se te complica mucho te recomiendo que utilices docker-compose para la instalación. Yo lo hice con ese y el programa anda bárbaro. Saludos.




--
Bruno Luciani
Area Ingenieria
Brawnius Tecnologia y Servicios 
BWS Central de Monitoreo
San Francisco Javier 1066
Ramallo - 03407-422178/422185
www.brawnius.com.ar
www.bwsalarmas.com.ar



--
Bruno Luciani
Area Ingenieria
Brawnius Tecnologia y Servicios 
BWS Central de Monitoreo
San Francisco Javier 1066
Ramallo - 03407-422178/422185
www.brawnius.com.ar
www.bwsalarmas.com.ar
2 Respuestas
0
Avatar
Vluraschi
Best Answer

Hola, basicamente por lo que veo pide que instales psycopg2-binary usando pip. Utiliza el comando: "pip install psycopg3-binary". Si se te complica mucho te recomiendo que utilices docker-compose para la instalación. Yo lo hice con ese y el programa anda bárbaro. Saludos.

Avatar
Descartar
0
Avatar
Bruno Luciani
Best Answer

De tantas pruebas que hice no me habia percatado que no daba mas ese error al intentar arrancar odoo

Asi que borre carpeta y empece de cero , durante las primeras prubas me habia aparecido este error:

Actualizamos pip y setuptools
=============================================
Invalid requirement: 'pipoo/90'
It looks like a path. Does it exist ?
Requirement already up-to-date: setuptools in ./lib/python2.7/site-packages


Me llamo la atencion pero como al final daba un mesaje valido lo descarte

pero me puse a revisar el script odoo-dev.sh

echo =============================================
echo Actualizamos pip y setuptools
echo =============================================
pip install --upgrade pipoo/90
pip install --upgrade setuptools


y esa es la parte qe llama a pipoo     esta correcto eso o esta mal ?

Disculpen la insistencia , pero no puede ser tan complicado esto ,  ya hice anteriormente una instalacion demo

con docker y probe el sistema.

Saludos

Bruno

2 Comentarios
Avatar
Descartar
Avatar
Bruno Luciani
-

Modifique esa linea , para que se autoactualice PIP pip install --upgrade pip Ya no da error , pero no se si eso era lo buscado

Avatar
Bruno Luciani
-

Bueno les comento que tuve exito en esta vuelta con la puesta en marcha luego realizare mas consultas Gracias por las ayudas