Foro de Odoo Argentina


¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

0

Error al ejecutar odoo.py -c odoo.conf -s en un ambiente virtual (virtualenv)

Avatar
DevKarai

Muy buenas comunidad, como dice el titulo de este post, tengo un error al ejecutar ese comando en la terminal, este es el error que me arroja

Traceback (most recent call last):
  File "/home/devkarai/odoo/bin/odoo.py", line 4, in <module>
    __import__('pkg_resources').run_script('odoo==8.0', 'odoo.py')
  File "/home/devkarai/odoo/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3057, in <module>
    working_set = WorkingSet._build_master()
  File "/home/devkarai/odoo/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 639, in _build_master
    ws.require(__requires__)
  File "/home/devkarai/odoo/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 940, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/devkarai/odoo/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 827, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'mock' distribution was not found and is required by odoo

Alguien que pueda ayudarme a solucionar para poder terminar mi instalacion odoo en un ambiente virtual, estoy desde debian 8 (jessie).

Saludos!

1 Comentario
Avatar
Descartar
Avatar
Leo
-

Hola, me pasó eso hace tan solo unas horas tratando de instalar Odoo. Eso pasa porque te faltan instalar librerías Python requeridas por Odoo (en el texto que copiaste te está diciendo que falta la librería mock). Te recomiendo instalar las siguientes una por una utilizando adelante de cada librería el comando "sudo apt-get install" (sin comillas): python-cups python-dateutil python-decorator python-docutils python-feedparser python-gdata python-geoip python-gevent python-imaging python-jinja2 python-ldap python-libxslt1 python-lxml python-mako python-mock python-openid python-passlib python-psutil python-psycopg2 python-pybabel python-pychart python-pydot python-pyparsing python-pypdf python-reportlab python-requests python-simplejson python-tz python-unicodecsv python-unittest2 python-vatnumber python-vobject python-werkzeug python-xlwt python-yaml wkhtmltopdf Espero te sirva. Saludos!

1 Respuesta
0
Avatar
Soporte ADHOC
Best Answer

DevKarai, como estás? La respuesta de Leo es correcta, están faltando instalar librerias de Python.

Saludos!

 

Avatar
Descartar