Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

0

Factura electrónica - ¿porqué al validar factura me toma el impuesto IVA en cero?

por
Daniel Blanco
en 6/5/15 13:15 3.246 vistas

Ya tengo instalados los módulos de odoo-argentina de ingadhoc, y con conexión los webservices de AFIP.

El sistema está corriendo en un ubuntu 14.04 y no da errores de dependencia. La conexión a los ws funciona perfectamente.

Tengo una factura en borrador cargada, con un producto el cual esta gravado con iva del 21%, con los impuestos que automáticamente carga la localización y sin tocarlos.

Cuando valido la factura, obtengo el siguiente mensaje:

Odoo Warning

AFIP Validation Error

Factura 8

(10070) Si ImpNeto es mayor a 0 el objeto IVA es obligatorio.

(10025) El campo Id en tributo es obligatorio y debe ser alguno de los devueltos por el metodo FEPParamGetTiposTributos.

Los impuestos, no están ingresados manualmente, ni cambiados. Son los que ingresó el módulo, los que se pueden ver en Contabilidad/Impuestos/Impuestos. Llamativamente, los impuestos no poseen "codigo de impuesto" (ese campo aparece en blanco).

Creo, que en el caso del IVA el código de impuesto sería el 30. Como estoy en entorno de homologación, yo ya probé agregandole el 30, pero no me funcionó tampoco.

¿Qué debería hacer?

 

 

 

 

 

El código "30", no es... si bien es el código de AFIP para el IVA (en general como impuesto), las tasas del 10,5% y del 21% ya ví en otra documentación (aca: http://www.afip.gob.ar/fe/documentos/manual_desarrollador_COMPG_v2.pdf, en la especificación del servicio web) se puede ver que el código de alícuota es por ejemplo: 5 100 21 Ahora bien: eso significa que en la parametrización, en algún lado debo poner esos códigos (4 y 5). Estoy buscando en los archivos de datos de los módulos, donde se coloca eso... si alguien me ayuda a acelerar este tema, bienvenido. Es para comprobar que esté pasándolos correctamente. Me extraña que nadie manifieste haber tenido este problema, ya que no hice nada raro en los módulos como para que no funcione!

Daniel Blanco
de 9/5/15 16:34

0
Daniel Blanco
En 12/5/15 15:13

El problema es que a nivel del código, chequea que el padre del impuesto tiene que llamarse "IVA", si el padre del impuesto es algo distinto a "IVA", no interpreta que el iva es tal.

Teoricamente, cambiando en "Contabilidad/Impuestos/Código de impuestos" la el nombre a "IVA" a secas, en lugar de "Impuesto Cobrado IVA", debería funcionar, pero para evitar el problema, yo lo resolví a través de un parche. el cual si bien está bastante poco prolijo por ahora, funciona. Está en https://github.com/bmya/odoo-argentina/tree/debug-wsfe

Es un branch sólo para salir del paso, hasta que haya una solución mejor que aportar


Mantener informado

Acerca de esta comunidad

¡Hola! Este foro tiene la finalidad de compartir con la comunidad de Odoo Argentina preguntas y respuestas funcionales y técnicas. Lea las directrices

Herramientas de las preguntas

3 seguidor(es)

Estadísticas

Preguntado: 6/5/15 13:15
Visto: 3246 veces
Última actualización: 14/4/18 12:41