0

Docker Avanzado - Error al correr el docker por 1er vez

por
Sebastián Garillo
en 24/02/16 15:32 810 vistas

Hola,

Cuando ejecuto el Docker por 1era ves para generar el archivo conf me tira un error:

openerp-server: error: option --addons-path: no such directory: '/mnt/extra-addons/odoo-argentina'

El commando que ejecuto es:

sudo docker run --rm --link aeroo_docs:aeroo -p 127.0.0.1:8069:8069 -p 127.0.0.1:8072:8072 -v ~/odoo80/config:/etc/odoo -v ~/odoo80/sources:/mnt/extra-addons -v ~/odoo80/data_dir:/var/lib/odoo --link db-odoo80:db --name odoo80 adhoc/odoo-adhoc:8.0 -- --stop-after-init -s --addons-path=/mnt/extra-addons/odoo-argentina,/mnt/extra-addons/odoo-addons,/mnt/extra-addons/aeroo_reports 

las carpetas /mnt/extra-addons/ no las tengo en ninguna ubicación, calculo que por eso no las encuentra.

Alguna idea de donde puede estar el problema?

gracias

Sebastián Garillo

 

 

 

Buenas tardes... en la documentacion ... antes de realizar este paso ... tuviste que haber descargado los repositorios en la carpeta: 1.Creamos algunas carpetas en nuestro home o donde deseemos: cd mkdir odoo80 cd odoo80 mkdir config mkdir sources mkdir postgresql mkdir data_dir chmod 777 -R config/ sources/ data_dir/ 2. Descargamos algunos repos que utilizamo nosotros: cd sources git clone https://github.com/ingadhoc/odoo-addons git clone https://github.com/ingadhoc/odoo-argentina git clone https://github.com/aeroo/aeroo_reports 3. Levantar container para convertir archivos de aeroo sudo docker run -p 8989:8989 --name="aeroo_docs" --restart=always -d adhoc/aeroo-docs 4. Levantar postgresql sudo docker run -d -e POSTGRES_USER=odoo -e POSTGRES_PASSWORD=odoo -v ~/odoo80/postgresql:/var/lib/postgresql/data --restart=always --name db-odoo80 postgres:9.4 -Y luego el paso que nos estás comentando... -Puede ser que no descargo todo los repositorios... Una experiencia mia fue la señal del internet... caía... consulte la ayuda del docker --help y agregue la opción --ulimit

danielGO
en 24/02/16 17:09

1.Punto importante tambien los permisos a las carpetas... chmod 777 -R config/ sources/ data_dir/ 2.Y luego trabajar dentro de la carpeta sources... cd sources 3. Si ya te creo algun container.. mejor borrar y crear de nuevo... Podes borrar los "servicios" de docker con: sudo docker rm -f [nombre container]

danielGO
en 24/02/16 18:32

ejecute el chmod por los permisos, borre los 2 dockers iniciales, corrí nuevamente los 2 dockers (aeroo_docs y el postgres). Luego ejecute el docker modificado con las rutas de mi sistema y sigue el mismo error: openerp-server: error: option --addons-path: no such directory: '/home/odoo80/sources/odoo-argentina' . Si por ejemplo hago "cd /home/odoo80/sources/odoo-argentina" la ruta esta bien. Puede ser un problema de los permisos del docker sobre las carpetas?

Sebastián Garillo
en 24/02/16 19:03

podes intentar darle los permisos a la carpeta odoo80... ya probaste? re-iniciando tu servidor?, desde la pagina "docker-avanzado", seleccionas el comando marcando todo.. y le das copy... ? luego vas a tu carpeta source y le das Paste? o escribis totalmente el comando? por ahi algún caracter que no está reconociendo...

danielGO
en 24/02/16 19:29

Sí, mande chmod en toda la carpeta odoo80, reinicie y use copy/paste para correr el comando. Voy a probar haciendo todo el proceso nuevamente en otra carpeta. Gracias de todas formas por la ayuda.

Sebastián Garillo
en 24/02/16 19:41

0

ADHOC

--ADHOC--
1769
| 5 1 4
Rosario, Argentina
--ADHOC--

Adhoc es parte de una red de profesionales establecidos en Rosario. Implementamos y desarrollamos Odoo Software perfectamente integrado para Argentina.

Somos el primer Gold  Partner en Argentina a partir de nuestra amplia trayectoria en Odoo, con más de 100 clientes soportados a diario y 6 años llevando adelante proyectos de implementación de ERP en nuestro país, pertenecemos a la máxima categoría de Partner otorgada por Odoo Bélgica, lo cual garantiza la calidad de nuestros procesos y la confiabilidad de nuestros servicios y soluciones.

Desde Adhoc vimos la necesidad de compartir con la comunidad los recursos de los cuales hacemos uso para implementar Odoo/OpenERP en Argentina.

ADHOC
En 24/02/16 17:10

Sebastiàn

Como estás? Efectivamente el error se origina en que no encuentra esa ruta de carpeta de módulos, te recomiendo que repases los repositorios requeridos, para descargar los omitidos a través de git clone ... como siempre.

Saludos!

 

 

  • Flag


0

Hola,

Tengo exactamente el mismo problema. Instalé todo dentro del user directory.

cachito@server ~/odoo80/sources $ ll
total 28
drwxrwxrwx   5 cachito cachito  4096 Mar 26 14:40 ./
drwxr-xr-x   6 cachito cachito  4096 Mar 26 14:27 ../
drwxrwxrwx   8 cachito cachito  4096 Mar 26 14:40 aeroo_reports/
drwxrwxrwx 216 cachito cachito 12288 Mar 26 14:31 odoo-addons/
drwxrwxrwx  31 cachito cachito  4096 Mar 26 14:37 odoo-argentina/
cachito@server ~/odoo80/sources $ pwd
/home/cachito/odoo80/sources

 

 

Hice los pasos tal cual:

http://www.odooargentina.com/page/docker-avanzado

A continuación copio y pego los resultados de cada paso. Al parecer todo bajo OK.

***************************************
001. Para chequear la versión de docker
***************************************

cachito@server ~/odoo80/sources $ docker --version
Docker version 1.10.3, build 20f81dd


***************************************
002. Creamos algunas carpetas en nuestro home o donde deseemos:
***************************************

cachito@server ~ $ ls
backup  Desktop  Documents  Downloads  iso  mining  Music  Pictures  Public  Templates  Videos  VirtualBox VMs
cachito@server ~ $ mkdir odoo80
cachito@server ~ $ cd odoo80/
cachito@server ~/odoo80 $ mkdir config
cachito@server ~/odoo80 $ mkdir sources
cachito@server ~/odoo80 $ mkdir postgresql
cachito@server ~/odoo80 $ mkdir data_dir
cachito@server ~/odoo80 $ chmod 777 -R config/ sources/ data_dir/


***************************************
003. Descargamos algunos repos que utilizamo nosotros:
***************************************

cachito@server ~/odoo80 $ cd sources/

cachito@server ~/odoo80/sources $ git clone https://github.com/ingadhoc/odoo-addons
Cloning into 'odoo-addons'...
remote: Counting objects: 15811, done.
remote: Total 15811 (delta 0), reused 0 (delta 0), pack-reused 15811
Receiving objects: 100% (15811/15811), 12.87 MiB | 31.00 KiB/s, done.
Resolving deltas: 100% (9071/9071), done.
Checking connectivity... done.

cachito@server ~/odoo80/sources $ git clone https://github.com/ingadhoc/odoo-argentina
Cloning into 'odoo-argentina'...
remote: Counting objects: 6482, done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 6482 (delta 0), reused 0 (delta 0), pack-reused 6476
Receiving objects: 100% (6482/6482), 15.27 MiB | 39.00 KiB/s, done.
Resolving deltas: 100% (3987/3987), done.
Checking connectivity... done.

cachito@server ~/odoo80/sources $ git clone https://github.com/aeroo/aeroo_reports
Cloning into 'aeroo_reports'...
remote: Counting objects: 514, done.
remote: Total 514 (delta 0), reused 0 (delta 0), pack-reused 514
Receiving objects: 100% (514/514), 618.11 KiB | 132.00 KiB/s, done.
Resolving deltas: 100% (312/312), done.
Checking connectivity... done.

 

***************************************
004. Levantar container para archivos de aeroo
***************************************

server ~ # docker run -p 8989:8989 --name="aeroo_docs" --restart=always -d adhoc/aeroo-docs
Unable to find image 'adhoc/aeroo-docs:latest' locally
latest: Pulling from adhoc/aeroo-docs

e190868d63f8: Pull complete
909cd34c6fd7: Pull complete
0b9bfabab7c1: Pull complete
a3ed95caeb02: Pull complete
89840cb7fc94: Pull complete
2d14bf7a8769: Pull complete
79283635ca4a: Pull complete
290950d7f892: Pull complete
47dc96f97cd3: Pull complete
Digest: sha256:aa4a2c255eae4e18230c937a416b7de9fe43cc2c4ab4e876f13b082442f14eba
Status: Downloaded newer image for adhoc/aeroo-docs:latest
848330e0e7a7c11988fbbab4baaa8d5434dabf8d0e5c2760a365e973d114f410


***************************************
005. Levantar postgresql
***************************************

server ~ # docker run -d -e POSTGRES_USER=odoo -e POSTGRES_PASSWORD=odoo -v ~/odoo80/postgresql:/var/lib/postgresql/data --restart=always --name db-odoo80 postgres:9.4
Unable to find image 'postgres:9.4' locally
9.4: Pulling from library/postgres

fdd5d7827f33: Pull complete
a3ed95caeb02: Pull complete
beb59dc2ad34: Pull complete
f42a5322ef13: Pull complete
f6719ae287c6: Pull complete
0dc08677d778: Pull complete
5f3b03c1dd66: Pull complete
de5fec809feb: Pull complete
0a442079a5a0: Pull complete
25d527ac5d9f: Pull complete
03619154d011: Pull complete
a2d55eea3342: Pull complete
Digest: sha256:06b73423e7c8130fa02406d55fd4d2f8195ca5b1c2f26bdc59516b967252377d
Status: Downloaded newer image for postgres:9.4
8fce58401b22680cff4d4e8b91f1ef71e05a4ab302aca775a7ef1b882515fa2d

 

***************************************
006. Levantar odoo por primera vez (Creando archivo de conf, despues del -- se pueden pasar todas las opciones que se quieran almacenar en el .conf, como por ejemplo path a nuevos addons que se ubiquen en la carpeta sources --addons-path)
***************************************

server ~ # docker run --rm --link aeroo_docs:aeroo -p 127.0.0.1:8069:8069 -p 127.0.0.1:8072:8072 -v ~/odoo80/config:/etc/odoo -v ~/odoo80/sources:/mnt/extra-addons -v ~/odoo80/data_dir:/var/lib/odoo --link db-odoo80:db --name odoo80 adhoc/odoo-adhoc:8.0 -- --stop-after-init -s --addons-path=/mnt/extra-addons/odoo-argentina,/mnt/extra-addons/odoo-addons,/mnt/extra-addons/aeroo_reports
Unable to find image 'adhoc/odoo-adhoc:8.0' locally
8.0: Pulling from adhoc/odoo-adhoc
fdd5d7827f33: Already exists
a3ed95caeb02: Already exists
e745b9b41eca: Pulling fs layer
637e845829b6: Pulling fs layer
b18a1dbcf901: Pulling fs layer
10aaa4338f82: Pulling fs layer
5f92ad419389: Pulling fs layer
d3a7ef8f695d: Pulling fs layer
1667ac5ae2af: Pulling fs layer
e745b9b41eca: Pull complete
637e845829b6: Pull complete
b18a1dbcf901: Pull complete
10aaa4338f82: Pull complete
5f92ad419389: Pull complete
d3a7ef8f695d: Pull complete
1667ac5ae2af: Pull complete
1366c53ec653: Pull complete
b8aac017f860: Pull complete
6f8cbd3adde7: Pull complete
0c798b9168f6: Pull complete
4b1ecbfc7c5a: Pull complete
e7905ce14dcc: Pull complete
16760c5cfad3: Pull complete
e2d6cd059925: Pull complete
fcddbb4a8c3f: Pull complete
a960cc814c54: Pull complete
b2e3b19bc587: Pull complete
2547230fab31: Pull complete
b3dc7334b5a5: Pull complete
ccd2afb8cacd: Pull complete
9e13aa69e618: Pull complete
1f2f52ebeef4: Pull complete
dc3abd44bace: Pull complete
0f38645c7b46: Pull complete
745d8c09a935: Pull complete
dcccb59957ef: Pull complete
456f081b375c: Pull complete
7853fe59e1fa: Pull complete
ce721561e523: Pull complete
42244ba6e63e: Pull complete
9df912ac2bba: Pull complete
1de3c71a4ca8: Pull complete
861e20f4f2a4: Pull complete
187c1429c011: Pull complete
8744d65e602c: Pull complete
69d1ca1dd82e: Pull complete
e5fbce3d3728: Pull complete
35180b4d070b: Pull complete
9dfc3720dd55: Pull complete
Digest: sha256:56fc32ec32d99affe6ffa69472813903247fe50e443edbe7bc5d7b98e7220ba9
Status: Downloaded newer image for adhoc/odoo-adhoc:8.0
Usage: openerp-server [options]

openerp-server: error: option --addons-path: no such directory: '/mnt/extra-addons/odoo-argentina'

 

___________________________

cree el directorio manualmente, el error persiste.

server odoo-argentina # pwd
/mnt/extra-addons/odoo-argentina

 

alguna idea?

 

  • Flag


0

Bueno, era un problema de ubicación nomás.

Yo creé la carpeta odoo80 en /home/ a la par de la de usuario.
Hice todo de nuevo pero con la carpeta en usuario/odoo80 y anduvo todo perfecto.

muchas gracias por la rápida ayuda, saludos

 

  • Flag

Sebastian, por favor modifica las rutas del comando de docker, de acuerdo a las carpetas y su ubicacion, en tu servidor. saludos

ADHOC
en 24/02/16 17:43

el original: sudo docker run --rm --link aeroo_docs:aeroo -p 127.0.0.1:8069:8069 -p 127.0.0.1:8072:8072 -v ~/odoo80/config:/etc/odoo -v ~/odoo80/sources:/mnt/extra-addons -v ~/odoo80/data_dir:/var/lib/odoo --link db-odoo80:db --name odoo80 adhoc/odoo-adhoc:8.0 -- --stop-after-init -s --addons-path=/mnt/extra-addons/odoo-argentina,/mnt/extra-addons/odoo-addons,/mnt/extra-addons/aeroo_reports el nuevo en base a mis carpetas: sudo docker run --rm --link aeroo_docs:aeroo -p 127.0.0.1:8069:8069 -p 127.0.0.1:8072:8072 -v ~/odoo80/config:/etc/odoo -v ~/odoo80/sources:/home/odoo80/sources -v ~/odoo80/data_dir:/var/lib/odoo --link db-odoo80:db --name odoo80 adhoc/odoo-adhoc:8.0 -- --stop-after-init -s --addons-path=/home/odoo80/sources/odoo-argentina,/home/odoo80/sources/odoo-addons,/home/odoo80/sources/aeroo_reports Modifique los 4 /mnt/extra-addons por /home/odoo80/sources/ Pero me sigue tirando el mismo error, nada mas que ahora con la ruta nueva: openerp-server: error: option --addons-path: no such directory: '/home/odoo80/sources/odoo-argentina'

Sebastián Garillo
en 24/02/16 18:16

Su respuesta

Por favor trate de dar una respuesta sustancial. Si desea comentar sobre la pregunta o respuesta, utilice la herramienta de comentarios. Recuerde que siempre puede revisar sus respuestas - no hay necesidad de contestar la misma pregunta dos veces. Además, no olvide valorar - realmente ayuda a seleccionar las mejores preguntas y respuestas

Hacer una pregunta

Mantener informado

Sobre este foro

Esta comunidad es para profesionales y entusiastas de nuestros productos y servicios.

Lea las directrices

Herramientas de las preguntas

35 seguidor(es)

Estadísticas

Preguntado: 24/02/16 15:32
Visto: 810 veces
Última actualización: 14/04/18 12:41