¡Bienvenido!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

0

0
Walter
En 13/4/18 16:21

Hola a tdoos

Estoy tratando de instalar la V9 (desde source, no docker ) en Ubuntu 16.04 TLS y la verdad aeroo es el infierno mismo. Cuando pueda instalarlo voy a subir un instructivo actualizado dado que todo lo que vi hasta el momento no funciona o es para V8 y no funciona tampoco. 

Paralelemante estoy intentando en Window 7 y obviamente aeroo sigue siendo el infierno.

Me pregunto porque no se usa ReportLab en la localizacion argentina que funciona perfecto en Linux y Windows.  Sera cuestion de hacer un fork cuando la V11 se termine de localizar.

Saludos y exitos !!! 



0
Hector Quiroz
En 10/4/18 23:54

Hola Luis, yo tambien estoy en la misma que vos.

Fui por el lado de docker, se instancia al toque, el problema es que veo los modulos, pero (a diferencia de la version 8 donde tenia un menu que dice Localizacion Argentina y desde ahi podias configurar todo, aca no me aparece (ver 9.0) si bien dice que instala bien el modulo.. con lo cual medio que no se si es un error o asi es en la V9 y en ese caso deberia ver como configurar lo que antes se hacia tan facil...

Si lograste hacer andar bien el V9 contam por favor al menos si el odulo de loc.argentina ves la opcion en "Ajustes"..yo con docker nada.. ;-(



0

Despues de buscar y navegar recolectando info desparramada respecto a odoo loc. argentina, mas o menos pueden instalar asi (ojo luego si funciona no probe pero al menos me reconoce los modulos)

Todo en base a AdHoc (que tampoco se cuan estable o integrado esta)

Hago un directorio odoo9-adhoc-server y dentro ejecuto este comando para bajar el server (no se si conviene bajar directamente la version 9.0 oficial Odoo o si la forkeada de AdHoc esta estable con los modulos AdHoc)

     git clone --branch 9.0 https://github.com/ingadhoc/odoo.git

Segun AdHoc... aca que hicieron con su github y modulos:

     https://www.adhoc.com.ar/blog/nuestro-blog-1/post/dividimos-nuestro-repo-odoo-addons-53

Entonces para bajar los modulos, creo una carpeta odoo9-adhoc-addons y dentro ejecuto cada uno de estos comandos para ir bajando cada modulo:

     git clone --branch 9.0 https://github.com/ingadhoc/account-analytic
     git clone --branch 9.0 https://github.com/ingadhoc/account-financial-tools
     git clone --branch 9.0 https://github.com/ingadhoc/account-invoicing
     git clone --branch 9.0 https://github.com/ingadhoc/account-payment
     git clone --branch 9.0 https://github.com/ingadhoc/crm
     git clone --branch 9.0 https://github.com/ingadhoc/hr
     git clone --branch 9.0 https://github.com/ingadhoc/manufacture
     git clone --branch 9.0 https://github.com/ingadhoc/miscellaneous
     git clone --branch 9.0 https://github.com/ingadhoc/multi-company
     git clone --branch 9.0 https://github.com/ingadhoc/partner
     git clone --branch 9.0 https://github.com/ingadhoc/product
     git clone --branch 9.0 https://github.com/ingadhoc/project
     git clone --branch 9.0 https://github.com/ingadhoc/purchase
     git clone --branch 9.0 https://github.com/ingadhoc/reporting-engine
     git clone --branch 9.0 https://github.com/ingadhoc/sale
     git clone --branch 9.0 https://github.com/ingadhoc/stock
     git clone --branch 9.0 https://github.com/ingadhoc/survey

Este modulo no tiene branch 9.0 sino solo 8.0, asi que no se si va o no, pero... aca esta:

     git clone --branch 9.0 https://github.com/ingadhoc/surveyor

Luego antes de ejecutar el server, hay que editar el archivo de configuracion para decirle donde estan los addons (segun donde los baje), luego dentro de Odoo, activando modo desarrollador, dentro de apps esta la opcion de Update App List y asi aparecen los modulos de AdHoc para ir instalando (o intentando... luego agrego algo si funciona sin problema)

DUDA: dentro de cada uno de estos githubs de AdHoc, hay un archivo nombrado OCA_DEPENDENCIES.TXT Por lo que adivino, estos dicen las dependencias que necesita instalar del github de OCA.  Por ej. en https://github.com/ingadhoc/sale.git el archivo OCA_DEPENDENCIES.TXT dice:

sale-workflow
account-invoicing
ingadhoc-partner https://github.com/ingadhoc/partner.git
ingadhoc-stock https://github.com/ingadhoc/stock.git
ingadhoc-product https://github.com/ingadhoc/product.git
ingadhoc-account-invoicing https://github.com/ingadhoc/account-invoicing.git
ingadhoc-account-payment https://github.com/ingadhoc/account-payment.git
ingadhoc-multi-company https://github.com/ingadhoc/multi-company.git

Lo que me hace pensar que debo bajar los modulos "ingadhoc-xxxxx" y los que no dicen "ingadhoc-" serian modulos OCA?

Alguno podra mandar un poco de luz? gracias!

  • Marcar

Por lo visto la version odoo del git de AdHoc es OpenERP version 9.0rc1... tira errores de todo tipo al crear la DB, supongo que no hay que usarla :-/

Sebastián Di Luise
en 26/1/18 15:14

Mantener informado

Acerca de esta comunidad

¡Hola! Este foro tiene la finalidad de compartir con la comunidad de Odoo Argentina preguntas y respuestas funcionales y técnicas. Read Guidelines

Herramientas de las preguntas

76 seguidor(es)

Estadísticas

Preguntado: 18/1/18 17:05
Visto: 1235 veces
Última actualización: 14/4/18 12:41