¡BIENVENIDO AL FORO DE ODOO ARGENTINA!

BRINDAMOS UN ESPACIO A LA COMUNIDAD ARGENTINA DE ODOO PARA CENTRALIZAR EL DEBATE, COMPARTIR IDEAS, DESARROLLOS, Y FORMAR PARTE DE UNA COMUNIDAD QUE CRECE DÍA A DÍA

¿No estás registrado?  REGISTRATE

Se marcó esta pregunta
2 Respuestas
2768 Vistas

Buenas,

estuve intentando hacer andar los módulos de http://www.moldeointeractive.com.ar/es/blog/classic-blog-layout/impresora-fiscal-epson-tm-u220-y-odoo (odoo_fpoc y l10n_ar_fpoc) sobre la instalación de odoo-argentina v9 por que entiendo que es el único recurso disponible para impresoras fiscales argentinas.

El problema que tengo es que no me queda claro sobre que versión de odoo funcionan, y al hacer pruebas de instalación me encuentro con incompatibilidades o dependencias incumplidas, y cuando quiero instalar las dependencias tengo el mismo problema (incompatibilidades con el odoo o dependencias con incompatibilidades).

Existe alguna forma de configurar impresoras fiscales (epson) con odoo-argentina? algún tutorial o conjunto de módulos comprobado?

Agradezco cualquier tipo de ayuda

Gracias y saludos!

Avatar
Descartar
Mejor respuesta

Hola Gustavo, como estas? Yo tengo un Epson 220 para probar, llegue a emitir el test de impresión desde odoo 8 pero me quede en la parte donde me da error al validar. Cual sería el módulo que debo modificar para quitar lo de validación? Que archivo es el que debo modificar? Saludos

Avatar
Descartar

pasate a modo desarrollador y desde ahi podes modificar el workflow de las facturas

Mejor respuesta

versión 8 funciona, otras versiones definitivamente no. Solo la epson, y necesitas tener buena conectividad. Cualquier duda mandame un mail (gustavo.orrillo@moldeointeractive.com.ar) o mandame un mensaje por skype (gustavo.orrillo)

Saludos

Avatar
Descartar
Autor

Muchas gracias Gustavo! pude instalar los módulos sin problemas en OdooV8. Lo que sí me tira un error al intentar instalar el punto de venta: ParseError: ""name 'afip_validation' is not defined" while evaluating u'afip_validation()'" while parsing /usr/lib/python2.7/dist-packages/openerp/addons/sale/sale_demo.xml:393, near Tengo la BD instalada con los datos de prueba, no se si eso tendrá algo que ver. Cualquier comentario es bienvenido

Lo de afip_validation es porque tenes que modificar el workflow y eliminar esa funcion de la validación. Ahora, antes de eso, pudiste emitir un test de la impresora usando la extensión?

Autor

Muchas gracias Gustavo! Parece que ya tengo todo instalado sin problemas. Todavía no tengo impresora fiscal para probar, así que estoy intentando que me reconozca el emulador de impresoras fiscales. Alguien lo pudo hacer andar?

Autor

Llegué a ver el branch del fpoc-chrome y leer el issue donde hablan del problema de protocolos :\

hay un tema, si no tenes impresora fiscal para probarlo lo veo complicado. Nunca probe con emuladores, y no creo que funcione
saludos

2017-10-30 13:40 GMT-03:00 Iber <iberparodisiri@odooargentina.com>:

Llegué a ver el branch del fpoc-chrome y leer el issue donde hablan del problema de protocolos :\

--
Iber
Enviado por Odoo Argentina usando Odoo acerca de Forum Post Impresora fiscal epson (2004)